8bitSpriteEditor

Z PMD 85 Infoserver

8bit Sprite Editor
Verzia: 1.3.2.24 / 8. januára 2015
Platforma: win32
Lokalizácia: en
Download: 8bit Sprite Editor v1.3.2.24
8bit Sprite Editor


8bit Sprite Editor je utilita, ktorá umožňuje:

  • vytváranie monochromatických spritov v 6 bitovom formáte pre VRAM PMD 85 alebo v 8 bitovom formáte napr. pre ZX Spectrum
  • sprity môžu byť maskované aj nemaskované
  • maximálna veľkosť spritu môže byť 96x96 bodov
  • v jednom sprite súbore môže byť 64 spritov (frejmov) danej veľkosti
  • výsledné binárne dáta je možné exportovať v rôznych formátoch
  • je možné importovať binárne dáta v rôznych formátoch




Obsah

ovládací panel

Ovládací panel obsahuje údaje o parametroch spritu, voľbu zobrazenia mriežky a určenie počtu frejmov.

byte mode

Určuje základný formát spritu, teda to, ako budú reprezentované výsledné binárne dáta.

  • 6bit reversed + hi 2bit zeros - formát, ktorý je vlastný reprezentácii VideoRAM PMD 85. Pixelová informácia je v 6-tich bitoch z bytu a horné 2 atribútové bity zostávajú nulové. Najľavejší bod je v 0. bite bytu.
  • classic 8bit - Pixelová informácia je vo všetkých 8-mych bitoch bytu. Najľavejší bod je v 7. bite bytu.

sprite size

  • Width - šírka spritu sa určuje v násobkoch 6-tich alebo 8-mych bodov. Šírka teda môže byť od 6/8 do 96 bodov.
  • Height - výška spritu môže byť od 1 do 96 bodov.

data format

Určuje cieľovú reprezentáciu binárnych dát spritu.

  • sprite data order sequence - určuje základný spôsob uloženia binárnych dát
    • by rows - po riadkoch
    • by columns - po stĺpcoch
  • masked sprite - určuje, že sprite bude maskovaný a ako budú reprezentované pixelové dáta spritu a jeho maska
    • mask byte interleaved with data byte - byte masky a byte dát sa striedajú
    • data byte interleaved with mask byte - byte dát a byte masky sa striedajú
    • whole mask, then sprite data - najprv celá maska, za ňou celé pixelové dáta
    • whole sprite data, then mask - najprv celé pixelové dáta, za nimi celá maska
    • mask row/col interleaved with data row/col - jeden riadok/stĺpec dát masky, za nimi jeden riadok/stĺpec pixelových dát
    • data row/col interleaved with mask row/col - jeden riadok/stĺpec pixelových dát, za nimi jeden riadok/stĺpec dát masky
  • Mask for attributes - pri 6 bitovom formáte určuje horné 2 atribútové bity pre dáta masky

grid

Zobrazenie mriežky a voľba jej veľkosti. Veľkosť jedného dieliku mriežky v oboch osiach môže byť v intervale 2 až 16. Umožňuje lepšiu orientáciu pri kreslení väčších spritov.

mouse position

Pod voľbou mriežky sa zobrazuje X/Y pozícia kurzora. Zároveň sa zobrazuje informácia, či je kurzor v pixelovej časti spritu alebo v maske.

frame

Zobrazenie čísla aktuálne editovaného spritu (frejmu) a voľba celkového počtu spritov. Posuvníkom na spodku ovládacieho panelu sa volí aktuálne editovaný sprite.

editácia spritu

Editácia spritu sa robí myšou. Ľavé tlačidlo myši body rozsvecuje, pravé tlačidlo zhasína.

menu Edit

V menu Edit sú operácie nad celým spritom alebo celou jeho maskou (položky, ktoré sa týkajú masky sú prístupné iba ak sa jedná o maskovaný sprite).

  • Copy sprite/mask - skopíruje sprite/masku do schránky
  • Paste sprite/mask - prepíše sprite/masku obsahom schránky
  • Merge with sprite/mask - spojí obsah schránky so spritom/maskou
  • Clear sprite/mask - zmaže sprite/masku
  • Invert sprite/mask - invertuje sprite/masku
  • Shift sprite/mask - posunie sprite/masku o jeden bod hore/vľavo/vpravo/dole
  • Generate standard mask - na základe kresby spritu, vygeneruje štandardnú masku
    (pre každý bod v sprite sa v maske vytvorí 9 "obtekajúcich" bodov)

menu View

V menu View sa volí zväčšenie (zoom) editačnej plochy 25%, 50%, 100% a 200%

načítanie a uloženie spritu

Pracovný (zdrojový) súbor spritu má príponu .sprite. Ukladajú sa doň všetky parametre spritu a samotné dáta spritu v pakovanej forme.

V menu File sú štandardné položky pre prácu s pracovným súborom: New, Open..., Save a Save as....

export spritu

Menu položka Export... v menu File umožňuje uložiť výsledné binárne dáta vo formáte definovanom v ovládacom paneli.

import spritu

8bit Sprite Editor umožňuje importovať binárne grafické dáta (menu položka Import... v menu File). Pred importom je potrebné nastaviť parametre spritov v zdrojovom binárnom súbore - bytový mód, veľkosť spritu a dátový formát. Počet spritov (framov) sa nastaví po importe automaticky.

Po importe je možné bez straty dát zmeniť parametre spritu, aj bytový mód, a tak je možné robiť konverziu dát medzi PMD 85 a napr. ZX Spectrom.

na záver

Ak máte k programu nejaké pripomienky alebo návrhy pre zlepšenie, budeme radi, ak nám napíšete na našu mailovú adresu, uvedenú na úvodnej stránke, prípadne nás kontaktujete na sociálnych sieťach.