Forum

From PMD 85 Infoserver

Jump to: navigation, search
:: back to start of topic :: back to topic list ::
Message
Author  Author ::  Martin Bórik
Posted  Posted ::  2009-12-08 02:26:53 PM
Subject  Subject ::  Re: Emulator pada na Access violation
Vldo a padá aj najnovšia verzia? ... pretože na tento bug som prišiel už dávno, ale mám pocit, že konkrétne toto som sa snažil odladiť s VMware a prišiel som na to, že s tým moc nenarobím, lebo padá inicializácia DirectSound, ale myslím, že ak si vypneš zvuk (Settings->Sound->Mute) tak by ti to už nemalo padať ... ale nie som si istý!
 
Message
Author  Author ::  Vldo
Posted  Posted ::  2009-12-08 02:41:08 PM
Subject  Subject ::  Re: Emulator pada na Access violation
Ano... spadla mi nejnovejší verze emulátoru, ale jak povídám... nezabýval bych se tím. Zvukovku normálně mám a na tenhle problém jsem přišel opravdu čistě náhodou
 
Message
Author  Author ::  Roman Bórik
Posted  Posted ::  2009-12-08 07:37:40 PM
Subject  Subject ::  Re: Emulator pada na Access violation
Je to tak, ako písal Martin. Ak neexistuje zvukové zariadenie, nepodarí sa inicializovať DirectSound. Žiaľ, v dvoch funkciách sa zabudlo na test úspešnosti inicializácie a to spôsobilo prístup na neexistujúci objekt.
Už som to opravil, ale nový release kvôli tomu robiť nebudeme. Ak by to niekto nutne potreboval, môžem mu výnimočne poslať samotný EXE súbor.
 
Message
Author  Author ::  Vldo
Posted  Posted ::  2009-12-09 06:47:41 AM
Subject  Subject ::  Re: Emulator pada na Access violation
Chlapci šikovní... není třeba kvůli tomu dělat nový release... napsal jsem to jen proto, abyste o tom věděli a třeba někdy v budoucnu, až vyrobíte novou verzi, tak to v ní opravili...
:: back to start of topic :: back to topic list ::