Forum

From PMD 85 Infoserver

Jump to: navigation, search
:: back to topic list ::
Message
Author  Author ::  ngx
Posted  Posted ::  2021-11-12 04:52:32 PM
Subject  Subject ::  Mato - problem po zapnuti
Zdravim vsetkych. Dostal sa ku mne Mato, avsak nefunguje. Po zapnuti zahra znelku (niekedy nie celkom do konca) a nasledne stuhne. Na obrazovke sa zobrazia nezmyselne znaky, obraz je zmrznuty, na klavesy nereaguje. Ked ho nasledne vypnem a znovu zapnem, uz nezahra a zobrazi sa biela obrazovka so zvislymi pasikmi sirokymi asi 1 pixel. Ked ho necham par minut odpocivat, tak opat zahra a zobrazi tie smeti.
Zial, som uplny noob.
Poradte mi, co treba vymenit? Pamate? Procesor?
Vdaka!
 
Message
Author  Author ::  Roman Bórik
Posted  Posted ::  2021-11-14 08:50:52 AM
Subject  Subject ::  Re: Mato - problem po zapnuti
Nuž, pokiaľ aspoň čiastočne zaznela tá úvodná znelka, tak asi CPU beží a je v poriadku. Zrejme beží aj Video procesor.
Určite treba overiť obsah EPROM. Asi by bolo treba preveriť aj DRAM, tie ale zrejme budú osadené napevno. A keďže sa zobrazuje obsah Video RAM, tak snáď budú v poriadku.
Keďže ale po vypnutí a zapnutí už znelka nezaznie, zjavne CPU niekde blúdi. Možno je problém v resetovacom obvode. Tam je tantalový kondenzátor a ten môže byť už po toľkých rokoch nespoľahlivý.
A na tej doske je tých tantalov viac. Skontrolovať, či rovno vymeniť by ich bolo asi vhodné všetky.
 
Message
Author  Author ::  ngx
Posted  Posted ::  2021-11-14 01:44:15 PM
Subject  Subject ::  Re: Mato - problem po zapnuti
Dakujem za opoved. Viete ma nejako navigovat (napr. linkou) ako overit obsah EPROM a pripadne funkcnost DRAM? RAM cipy su zial naozaj napajkovane priamo na doske, takze vymenit ich by bol pre mna problem. Bojim sa, aby som ich neuprazil, pripadne neznicil dosku. Ale pokial by som vedel zistit ci su ok, ak je to vobec mozne, nemusel by som do nich vobc rypat. Podla toho co pisete sa mi zatial zda, ze by problem mohol byt v EPROM. Ked ju vyberiem (jedina je v patici), Mato nabehne do tej druhej obrazovky (biela, s pasmi, bez znelky), predpokladam, ze nejaky monitor je spolu s basicom na tej epromke.
V inom prispevku som si precital, ze obsah eprom je mozne ziskat z emulatora. Viete ma prosim odkazat na nejaky programator, ktorym by som si vedel tu eprom napalit?
Vdaka za pomoc!
 
Message
Author  Author ::  Roman Bórik
Posted  Posted ::  2021-11-14 04:13:34 PM
Subject  Subject ::  Re: Mato - problem po zapnuti
Obsah EPROM overíte jedine tak, že ju prečítate v nejakom programátore (na nete sa ich dá nájsť mnoho - hotové, stavebnice i návody na stavbu) a porovnáte tento obsah s tým, ktorý je napr. súčasťou Emulátora - v adresári Rom je to súbor mato-mb.rom.
 
Message
Author  Author ::  ngx
Posted  Posted ::  2021-11-15 03:11:20 AM
Subject  Subject ::  Re: Mato - problem po zapnuti
Idem teda pozhanat programator. Podobne mi odpovedali aj na oldcomp.cz, vyskusam najprv obnovit resp. vymenit EEPROM a potom pripadne aj tie kondenzatory. Dufam, ze RAMky budu ok, lebo netusim, ako by som ich odletoval z dosky.
Dakujem!
:: back to topic list ::